
 

Data Analysis in Excel 365 

Introduction to Data Analysis 

Data analysis is the process of inspecting, cleaning, transforming, and modeling data to discover 

useful information, suggest conclusions, and support decision-making. Excel 365 provides powerful 

built-in tools for performing data analysis.  

 

 

 

Types of Data Analysis 

1. Descriptive Analysis – Summarizing data (average sales, totals). Tools: SUM, AVERAGE, Charts, 

PivotTables. 2. Diagnostic Analysis – Understanding why something happened. Tools: 

Filters, PivotTables, Conditional Formatting. 3. Predictive Analysis – Forecasting future outcomes. 

Tools: Forecast Sheet, Regression. 4. Prescriptive Analysis – Suggesting actions for optimization. 

Tools: Solver, Goal Seek. ■ Screenshot: Example tables and charts for each type. 

What-If Analysis Tools 

Excel provides three key What-If tools: • Goal Seek – Find input value for desired output. Example: 

Calculate required sales to reach target profit. Steps:  

1. Go to Data > What-If Analysis >  

Trainer Name:Kavita Navlani 

Microsoft Certified Trainer 

Corporate Trainer 



 

 

 

 

a. Goal Seek.  

b. Example : In a sheet ,Enter the Sales value in Cell D2 

c. Eneter the formula in e2 that is d2*10% 

d.  Set cell → Select result cell (profit). D3 To value → Enter target value (e.g., 100000).  

e.  By changing cell → Select variable (sales). Cell D2 

f.  

• Data Table – Sensitivity analysis with one or two variables.  

2.  



Example: Loan EMI for varying interest rates and tenure. 

 

Press Ok 

Solver Add-in 

Solver is used for optimization (maximize profit, minimize cost). Example: Optimize product mix to 

maximize profit under resource constraints. 

 

 Steps: 1. Enable Solver from Options > Add-ins.  

2. Define objective cell (e.g., total profit).  

3. Select decision variables (units to produce). 4 

. Add constraints (resource limits). 



 5. Click Solve.  

 

.also creates scenarios for scenarios analysis 

Data Analysis ToolPak 

 

ToolPak provides advanced statistical tools. Example: Descriptive Statistics.  

Steps: 1. Enable 

ToolPak (File > Options > Add-ins > Analysis ToolPak).  

2. Data > Data Analysis > Descriptive Statistics. 

 3. Select input range and summary statistics.  

 

Practice Exercises 

1. Use Goal Seek to calculate required sales for ■1,00,000 profit. 2. Create a two-variable Data 

Table for EMI (Interest Rate vs Tenure). 3. Use Solver to optimize product mix with constraints. 4. 

Build a PivotTable showing sales by region and category. 5. Generate a Forecast Sheet for sales 

data. ■ Screenshot: Exercise datasets and results. 



Summary & Key Takeaways 

• Excel 365 provides multiple tools for data analysis. • Use What-If Analysis and Solver for 

predictive & prescriptive tasks. • Use PivotTables and ToolPak for descriptive & diagnostic analysis. 

• Forecast Sheet helps in future predictions. Mastering these tools improves decision-making and 

analytical skills. 

 

 

PivotTables and PivotCharts 

PivotTables are used to summarize and analyze data interactively. Example: Analyze regional sales 

by product category.  

Pivot Tables in Excel 

  

Pivot tables are one of Excel's most powerful features. A pivot table allows you to extract the 

significance from a large, detailed data set. 

Our data set consists of 213 records and 6 fields. Order ID, Product, Category, Amount, Date and 

Country. 

 
Insert a Pivot Table 

To insert a pivot table, execute the following steps. 

1. Click any single cell inside the data set. 

2. On the Insert tab, in the Tables group, click PivotTable. 

 
The following dialog box appears. Excel automatically selects the data for you. The default location 

for a new pivot table is New Worksheet. 

3. Click OK. 



 
Drag fields 

The PivotTable Fields pane appears. To get the total amount exported of each product, drag the 

following fields to the different areas. 

1. Product field to the Rows area. 

2. Amount field to the Values area. 

3. Country field to the Filters area. 

 
Below you can find the pivot table. Bananas are our main export product. That's how easy pivot 

tables can be! 



 
  



Sort a Pivot Table 

To get Banana at the top of the list, sort the pivot table. 

1. Click any cell inside the Sum of Amount column. 

2. Right click and click on Sort, Sort Largest to Smallest. 

 
Result: 

 
Filter a Pivot Table 

Because we added the Country field to the Filters area, we can filter this pivot table by Country. For 

example, which products do we export the most to France? 

1. Click the filter drop-down and select France. 

Result: Apples are our main export product to France. 

 



Note: you can use the standard filter (triangle next to Row Labels) to only show the amounts of 

specific products. 

Change Summary Calculation 

By default, Excel summarizes your data by either summing or counting the items. To change the 

type of calculation that you want to use, execute the following steps. 

1. Click any cell inside the Sum of Amount column. 

2. Right click and click on Value Field Settings. 

 
3. Choose the type of calculation you want to use. For example, click Count. 

 
4. Click OK. 

Result: 16 out of the 28 orders to France were 'Apple' orders. 



 
Two-dimensional Pivot Table 

If you drag a field to the Rows area and Columns area, you can create a two-dimensional pivot 

table. First, insert a pivot table. Next, to get the total amount exported to each country, of each 

product, drag the following fields to the different areas. 

1. Country field to the Rows area. 

2. Product field to the Columns area. 

3. Amount field to the Values area. 

4. Category field to the Filters area. 

 
Below you can find the two-dimensional pivot table. 

https://www.excel-easy.com/data-analysis/pivot-tables.html#insert-pivot-table


 
Pivot Chart 

To easily compare these numbers, create a pivot chart and apply a filter. Maybe this is one step too 

far for you at this stage, but it shows you one of the many other powerful pivot table features Excel 

has to offer. 

 
  

https://www.excel-easy.com/examples/pivot-chart.html


Group Pivot Table Items in Excel 

  

This example teaches you how to group pivot table items. Learn how to group products and how to 

group dates by quarters. 

Below you can find a pivot table. Go back to Pivot Tables to learn how to create this pivot table. 

 
Group Products 

The Product field contains 7 items. Apple, Banana, Beans, Broccoli, Carrots, Mango and Orange. 

To create two groups, execute the following steps. 

1. In the pivot table, select Apple and Banana. 

2. Right click and click on Group. 

 
3. In the pivot table, select Beans, Broccoli, Carrots, Mango and Orange. 

4. Right click and click on Group. 

https://www.excel-easy.com/data-analysis/pivot-tables.html


 
Result: 

 
Note: to change the name of a group (Group1 or Group2), select the name, and edit the name in 

the formula bar. To ungroup, select the group, right click and click on Ungroup. 

5. To collapse the groups, click the minus signs. 



 
Conclusion: Apple and Banana (Group1) have a higher total than all the other products (Group2) 

together. 

Group Dates 

To create the pivot table below, instead of the Product field, add the Date field to the Rows area. 

The Date field contains many items. 6-Jan, 7-Jan, 8-Jan, 10-Jan, 11-Jan, etc. 

To group these dates by quarters, execute the following steps. 

1. Click any cell inside the column with dates. 

2. Right click and click on Group. 

 
3. Select Quarters and click OK. 



 
Note: also see the options to group by seconds, minutes, hours, etc. 

Result: 

 
Conclusion: Quarter 2 is the best quarter. 

Multi-level Pivot Table in Excel 

  

You can drag more than one field to an area in a pivot table. We'll look at an example of multiple 

row fields, multiple value fields and multiple report filter fields. 

Remember, our data set consists of 213 records and 6 fields. Order ID, Product, Category, Amount, 

Date and Country. 

 
Multiple Row Fields 

First, insert a pivot table. Next, drag the following fields to the different areas. 

1. Category field and Country field to the Rows area. 

2. Amount field to the Values area. 

https://www.excel-easy.com/data-analysis/pivot-tables.html#insert-pivot-table


 
Below you can find the multi-level pivot table. 



 
Multiple Value Fields 

First, insert a pivot table. Next, drag the following fields to the different areas. 

1. Country field to the Rows area. 

2. Amount field to the Values area (2x). 

https://www.excel-easy.com/data-analysis/pivot-tables.html#insert-pivot-table


 
Note: if you drag the Amount field to the Values area for the second time, Excel also populates the 

Columns area. 

Pivot table: 

 
3. Next, click any cell inside the Sum of Amount2 column. 

4. Right click and click on Value Field Settings. 



 
5. Enter Percentage for Custom Name. 

6. On the Show Values As tab, select % of Grand Total. 

 
7. Click OK. 

Result: 



 
Multiple Report Filter Fields 

First, insert a pivot table. Next, drag the following fields to the different areas. 

1. Order ID to the Rows area. 

2. Amount field to the Values area. 

3. Country field and Product field to the Filters area. 

 
4. Next, select United Kingdom from the first filter drop-down and Broccoli from the second filter 

drop-down. 

The pivot table shows all the 'Broccoli' orders to the United Kingdom. 

https://www.excel-easy.com/data-analysis/pivot-tables.html#insert-pivot-table


 
 

Frequency Distribution in Excel 

  

Did you know that you can use pivot tables to easily create a frequency distribution in Excel? You 

can also use the Analysis Toolpak to create a histogram. 

Remember, our data set consists of 213 records and 6 fields. Order ID, Product, Category, Amount, 

Date and Country. 

 
First, insert a pivot table. Next, drag the following fields to the different areas. 

1. Amount field to the Rows area. 

2. Amount field (or any other field) to the Values area. 

https://www.excel-easy.com/examples/histogram.html
https://www.excel-easy.com/data-analysis/pivot-tables.html#insert-pivot-table


 
3. Click any cell inside the Sum of Amount column. 

4. Right click and click on Value Field Settings. 



 
5. Choose Count and click OK. 

 
6. Next, click any cell inside the column with Row Labels. 



7. Right click and click on Group. 

 
8. Enter 1 for Starting at, 10000 for Ending at, and 1000 for By. 

9. Click OK. 

 
Result: 



 
To easily compare these numbers, create a pivot chart. 

10. Click any cell inside the pivot table. 

11. On the PivotTable Analyze tab, in the Tools group, click PivotChart. 

 
The Insert Chart dialog box appears. 

12. Click OK. 

Result: 

 
Pivot Chart in Excel 

  

A pivot chart is the visual representation of a pivot table in Excel. Pivot charts and pivot tables are 

connected with each other. 

Below you can find a two-dimensional pivot table. Go back to Pivot Tables to learn how to create 

this pivot table. 

https://www.excel-easy.com/data-analysis/pivot-tables.html#two-dimensional-pivot-table


 
Insert Pivot Chart 

To insert a pivot chart, execute the following steps. 

1. Click any cell inside the pivot table. 

2. On the PivotTable Analyze tab, in the Tools group, click PivotChart. 

 
The Insert Chart dialog box appears. 

3. Click OK. 

Below you can find the pivot chart. This pivot chart will amaze and impress your boss. 

 
Note: any changes you make to the pivot chart are immediately reflected in the pivot table and vice 

versa. 

Filter Pivot Chart 

To filter this pivot chart, execute the following steps. 

1. Use the standard filters (triangles next to Product and Country). For example, use the Country 

filter to only show the total amount of each product exported to the United States. 



 
2. Remove the Country filter. 

3. Because we added the Category field to the Filters area, we can filter this pivot chart (and pivot 

table) by Category. For example, use the Category filter to only show the vegetables exported to 

each country. 

 
Change Pivot Chart Type 

You can change to a different type of pivot chart at any time. 

1. Select the chart. 

2. On the Design tab, in the Type group, click Change Chart Type. 

 
3. Choose Pie. 



 
4. Click OK. 

Result: 

 
Note: pie charts always use one data series (in this case, Beans). To get a pivot chart of a country, 

swap the data over the axis. First, select the chart. Next, on the Design tab, in the Data group, click 

Switch Row/Column. 

Slicers in Excel 

  



Use slicers in Excel to quickly and easily filter pivot tables. Connect multiple slicers to multiple pivot 

tables to create awesome reports. 

Below you can find a pivot table. Go back to Pivot Tables to learn how to create this pivot table. 

 
To insert a slicer, execute the following steps. 

1. Click any cell inside the pivot table. 

2. On the PivotTable Analyze tab, in the Filter group, click Insert Slicer. 

 
3. Check Country and click OK. 

 
4. Click United States to find out which products we export the most to the United States. 

https://www.excel-easy.com/data-analysis/pivot-tables.html


 
Conclusion: bananas are our main export product to the United States. The report filter (cell B1) 

changes to United States. 

OK, that was pretty easy. Let's insert a second slicer. 

5. Click any cell inside the pivot table. 

6. On the PivotTable Analyze tab, in the Filter group, click Insert Slicer. 

 
7. Check Product and click OK. 

 
8. Select the slicer. 

9. On the Slicer tab, in the Slicer Styles group, click a slicer style. 

 
10. Use the second slicer. Click the Multi-Select button to select multiple products. 



 
Note: instead of using the Multi-Select button, hold down CTRL to select multiple items. 

To really impress your boss, execute the following steps. 

11. Insert a second pivot table. 

To connect both slicers to this pivot table, execute the following steps. 

12. Select the first slicer. 

13. On the Slicer tab, in the Slicer group, click Report Connections. 

 
14. Select the second pivot table and click OK. 

 
15. Repeat steps 12-14 for the second slicer. 

16. Use both slicers. 



 
Conclusion: the total amount of apples exported to Canada equals $24,867 (6 orders) and the total 

amount of oranges exported to Canada equals $19,929 (3 orders). 

17. Click the icon in the upper-right corner of a slicer to clear the filter. 



 
Note: we didn't export any beans or carrots to Canada. Try it yourself, download the Excel file and 

use slicers to create awesome reports. 

Update a Pivot Table in Excel 

  

Any changes you make to the data set are not automatically picked up by the pivot 

table. Refresh the pivot table or change the data source to update the pivot table with the applied 

changes. 

Refresh 

If you change any of the text or numbers in your data set, you need to refresh the pivot table. 

1. Click any cell inside the pivot table. 

2. Right click and click on Refresh. 



 
To refresh a pivot table automatically when opening an Excel file, execute the following steps. 

3. Click any cell inside the pivot table. 

4. On the PivotTable Analyze tab, in the PivotTable group, click Options. 

 
Excel shows the PivotTable Options dialog box. 

5. On the Data tab, check "Refresh data when opening the file". 

 
6. Click OK. 

From now on, whenever you open this Excel file, Excel will automatically refresh this pivot table 

(and all other pivot tables with this source data in this Excel file). 



Change Data Source 

If you change the size of your data set by adding or deleting rows/columns, you need to update the 

source data for the pivot table. 

1. Click any cell inside the pivot table. 

2. On the PivotTable Analyze tab, in the Data group, click Change Data Source. 

 
Tip: change your data set to a table before you insert a pivot table. This way your data source will 

be updated automatically when you add or delete rows/columns. This can save time. You still have 

to refresh though. 

Calculated Field/Item in Excel 

  

This example teaches you how to insert a calculated field or calculated item in a pivot table. 

Below you can find a pivot table. Go back to Pivot Tables to learn how to create this pivot table. 

 
Calculated Field 

A calculated field uses the values from another field. To insert a calculated field, execute the 

following steps. 

1. Click any cell inside the pivot table. 

2. On the PivotTable Analyze tab, in the Calculations group, click Fields, Items & Sets. 

 
3. Click Calculated Field. 

 
The Insert Calculated Field dialog box appears. 

4. Enter Tax for Name. 

https://www.excel-easy.com/data-analysis/tables.html
https://www.excel-easy.com/data-analysis/pivot-tables.html


5. Type the formula =IF(Amount>100000, 3%*Amount, 0) 

6. Click Add. 

 
Note: use the Insert Field button to quickly insert fields when you type a formula. To delete a 

calculated field, select the field and click Delete (under Add). 

7. Click OK. 

Excel automatically adds the Tax field to the Values area. 

Result: 

 
Calculated Item 

A calculated item uses the values from other items. To insert a calculated item, execute the 

following steps. 

1. Click any Country in the pivot table. 

2. On the PivotTable Analyze tab, in the Calculations group, click Fields, Items & Sets. 

 
3. Click Calculated Item. 



 
The Insert Calculated Item dialog box appears. 

4. Enter Oceania for Name. 

5. Type the formula =3%*(Australia+'New Zealand') 

6. Click Add. 

 
Note: use the Insert Item button to quickly insert items when you type a formula. To delete a 

calculated item, select the item and click Delete (under Add). 

7. Repeat steps 4 to 6 for North America (Canada and United States) and Europe (France, 

Germany and United Kingdom) with a 4% and 5% tax rate respectively. 

8. Click OK. 

Result: 



 
Note: we created two groups (Sales and Taxes). 

 

 

Forecasting Tools 

Excel 365 offers Forecast Sheet for time-series prediction. Example: Forecast monthly sales for 

next 12 months. Steps: 1. Select historical data. 2. Go to Data > Forecast Sheet. 3. Choose 

line/column chart, forecast end date. 4. Excel generates forecast with confidence intervals. 

Forecast Sheet dialog and output chart. 

Other Tools 

• Conditional Formatting – Highlight trends (e.g., top 10 sales).  

 

Formatting options. • Sparklines – Mini charts inside cells to show trends.  

Sparklines in worksheet.  

 

 

 

 

https://www.excel-easy.com/examples/group-pivot-table-items.html


• Power Query editor(ETL) – Import, clean, and transform data.  

Power Query Editor in Excel 365 

 

 



Introduction to Power Query 

 

    Power Query is a data connection technology in Excel that allows 

you to import, clean, transform, and combine data from multiple 

sources. 

    It automates the process of data preparation without coding. 

    Location: Data tab → Get & Transform Data group. 

 

 

Power Query Workflow (ETL Process) 

 

    1. Extract – Import data (Excel, CSV, Web, SQL, etc.). 

    2. Transform – Clean and reshape data (remove blanks, split 

columns, filter rows). 

    3. Load – Send the cleaned data back to Excel or Power BI. 

    4. Automate – Refresh the query anytime the source data changes. 

 

 

 

 

Key Features of Power Query Editor 

 

    • Import Data – From Excel, CSV, Text, Web, Databases, 

SharePoint.   

    • Transform Data – Remove rows/columns, split columns, filter rows, 

change data type, merge/append queries.   

    • Group By – Summarize (e.g., total sales by region).   

    • Pivot/Unpivot – Reshape data.   

    • Custom/Conditional Columns – Add logic & calculations.   

 

. 

Applied Steps & Query Settings 



 

    • Each transformation is recorded as a step in the right-hand panel.   

    • Steps can be renamed, reordered, or deleted.   

    • Queries are repeatable and refreshable.   

 

Load Data 

 

    • Load cleaned data back into: Excel Table, Pivot Table Report, or 

Data Model (Power Pivot).   

    • Choose “Load To…” for options.   

 

Practical Examples 

 

    1. Cleaning Sales Data – Import CSV, remove blanks, split Full 

Name, load cleaned table.   

    2. Merging Queries – Merge Sales and Customer tables using 

Customer ID.   

    3. Unpivoting Data – Convert month columns into rows.   

    4. Group By – Summarize sales by region.   

 

 

Advantages of Power Query 

 

    • No manual repetition – Refresh updates automatically.   

    • Handles large datasets efficiently.   

    • Works across multiple data sources.   

    • Integrates with Power BI.   
 Summary & Key Takeaways 

    • Power Query is an ETL tool inside Excel.   

    • All steps are recorded → Queries are reusable.   

    • Saves time, effort, and reduces human error.   

    • Essential for data cleaning, combining, and reshaping tasks.   


